Namespace declaration. xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" is missing in received invoices from Access Point

09/08/2012

We found strange issue of missing namespace declaration in couple of invoices that we recieved through our access point.

 

Customer is sending invoice to us invoice with namespace(xmlns:xsi) in root tag from Remote Access Point:

 

<Invoice xsi:schemaLocation="urn:oasis:names:specification:ubl:schema:xsd:Invoice-2 UBL-Invoice-2.0.xsd" xmlns="urn:oasis:names:specification:ubl:schema:xsd:Invoice-2" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:cac="urn:oasis:names:specification:ubl:schema:xsd:CommonAggregateComponents-2" xmlns:cbc="urn:oasis:names:specification:ubl:schema:xsd:CommonBasicComponents-2" xmlns:ext="urn:oasis:names:specification:ubl:schema:xsd:CommonExtensionComponents-2">

 

 

But when we receive invoice in our Access Point, there is missing namespace declartion xmlns:xsi (see below root tag). That is invoice have root tag:

 

<Invoice:Invoice xmlns:Invoice="urn:oasis:names:specification:ubl:schema:xsd:Invoice-2" xsi:schemaLocation="urn:oasis:names:specification:ubl:schema:xsd:Invoice-2 UBL-Invoice-2.0.xsd">

 

 

Now, I want to know whether it is intentionally removed by peppol library while reading SOAP envelope i.e. bug in reading envelope? 

 

OR

 

Is it problem with Remote Access Point, which is sending invoices to us?

 

If it is bug in peppol-library in this case, then I want to report it as bug.

 

Regards,

Arun Kumar

 

 

 

 

 

 

Component

Code

Category

bug

Comments

Mon, 13/08/2012 - 12:25

Update:

Issue has been resolved. It is because of conflicting jar.

 

Mon, 13/08/2012 - 14:11

Since this issue was not because of peppol library but presence of XSLT jar in classpath/integration environment, so I am marking it as closed without any fix.

 

 

The content of this field is kept private and will not be shown publicly.